• Wrong document? Swap it for free
  • Written by students who passed
  • Immediately available after payment
  • Read online or as PDF
Sell
Where do you study
Your language
Document preview thumbnail
Preview 3 out of 25 pages
Class notes

Aantekeningen computer networks

Document preview thumbnail
Preview 3 out of 25 pages

In dit document vind je alle stof die gevraagd wordt in de toets van het vak computer networks. Deze toets wordt gegeven in week 9. Al deze aantekeningen zijn compleet uitgewerkt en er zijn vaak afbeeldingen die de uitleg ondersteunen.

Content preview

Notities week 6, 7, 8
Client-server protocollen uit de applicatie laag van de internet protocolstack:

 Veel protocollen uit de applicatielaag volgen het client-server model
 Deze protocollen gebruiken in dat geval meestal TCP als transportlaag (TCP is betrouwbaar
en volgt ook de client-server-rolverdeling).
 Veel protocollen uit de applicatielaag zijn (door het verleden) tekst-georiënteerd. Dat
betekent dat tussen client en server leesbare ASCII-tekst heen en weer gaat.

TELNET:

 TELNET (RFC854)
o Maakt het werken op een computer vanaf een “remote terminal” mogelijk.
o Tekst georiënteerd.
o De server “luistert” op TCP-poort 23.
o Wordt vrijwel nooit meer gebruikt vanwege veiligheidsrisico’s:
 Er gaan leesbare data door het netwerk.
 Je bent niet zeker met wie je verbonden bent
o Soms nog in gebruik bij router management op beschermde netwerksegmenten.

SSH:

 SSH (SECURE SHELL, RFC 4251..4254)
 Opvolger van TELNET
 SSH luistert op TCP-poort 22.
 Dezelfde functie als TELNET (remote terminal)
 Lijkt dus op TELNET maar is wel beveiligd:
 Wordt zeer vaak toegepast bij remote beheer van computers, routers en switches.
 Encryptie van de data
 Authenticatie van de verbinding (server moet bij het verbinden aantonen over een bepaalde
key te beschikken).

Bekende clients voor TELNET/SSH op Windows:

 SSH via PowerShell
 Putty




SSH en Security:

,Als je voor de eerste keer een server bezoekt, word je gewaarschuwd en moet je toestemming
geven.




Na het geven van toestemming wordt bij alle volgende sessies automatisch gecontroleerd of het
dezelfde server is (door middel van een geheime sleutel).

HTTP (Hyper Tekst Transfer Protocol):

 Het meest bekende internetprotocol (RFC1945.2616)
 HTTP-clients kunnen webpagina’s bij HTTP-servers opvragen (requests).
 Webpagina’s bestaan uit een of meerdere webobjecten (html, jpg, javascript, etc.)
 HTTP-servers luisteren meestal naar poort 80 of poort 443 en geven antwoord op requests in
de vorm van replies.

 Tegenwoordig is HTTP voor een groot deel vervangen door de veilige versie (HTTPS over
poort 443).




HTTP request-PDU:

, Opbouw van de request HTTP-PDU:

Hier zie je de:

 Methode
 URL link
 Versie
 ASCII codes bij de volgende regel (<cr><if>) (in de header)
 Value (in de header)
 Bij een GET request is de payload leeg omdat je juist data opvraagt en niet verzendt.




URL (Uniform Resource Locator):

Document information

Study
Uploaded on
October 29, 2019
Number of pages
25
Written in
2019/2020
Type
Class notes
Professor(s)
Unknown
Contains
All classes
$12.73

Wrong document? Swap it for free Within 14 days of purchase and before downloading, you can choose a different document. You can simply spend the amount again.
Written by students who passed
Immediately available after payment
Read online or as PDF

Seller avatar
Reputation scores are based on the amount of documents a seller has sold for a fee and the reviews they have received for those documents. There are three levels: Bronze, Silver and Gold. The better the reputation, the more your can rely on the quality of the sellers work.
Eyespectre
3.4
(7)
Sold
59
Followers
34
Items
17
Last sold
8 months ago



Why students choose Stuvia

Created by fellow students, verified by reviews

Quality you can trust: written by students who passed their tests and reviewed by others who've used these notes.

Didn't get what you expected? Choose another document

No worries! You can instantly pick a different document that better fits what you're looking for.

Pay as you like, start learning right away

No subscription, no commitments. Pay the way you're used to via credit card and download your PDF document instantly.

Student with book image

“Bought, downloaded, and aced it. It really can be that simple.”

Alisha Student

Working on your references?

Create accurate citations in APA, MLA and Harvard with our free citation generator.

Working on your references?

Frequently asked questions