• Verkeerd document? Gratis ruilen
  • Geschreven door studenten die geslaagd zijn
  • Direct beschikbaar na je betaling
  • Online lezen of als PDF
Verkopen
Kies je studieland
Kies je taal
Document preview thumbnail
Voorbeeld 3 van de 25 pagina's
College aantekeningen

Aantekeningen computer networks

Document preview thumbnail
Voorbeeld 3 van de 25 pagina's

In dit document vind je alle stof die gevraagd wordt in de toets van het vak computer networks. Deze toets wordt gegeven in week 9. Al deze aantekeningen zijn compleet uitgewerkt en er zijn vaak afbeeldingen die de uitleg ondersteunen.

Voorbeeld van de inhoud

Notities week 6, 7, 8
Client-server protocollen uit de applicatie laag van de internet protocolstack:

 Veel protocollen uit de applicatielaag volgen het client-server model
 Deze protocollen gebruiken in dat geval meestal TCP als transportlaag (TCP is betrouwbaar
en volgt ook de client-server-rolverdeling).
 Veel protocollen uit de applicatielaag zijn (door het verleden) tekst-georiënteerd. Dat
betekent dat tussen client en server leesbare ASCII-tekst heen en weer gaat.

TELNET:

 TELNET (RFC854)
o Maakt het werken op een computer vanaf een “remote terminal” mogelijk.
o Tekst georiënteerd.
o De server “luistert” op TCP-poort 23.
o Wordt vrijwel nooit meer gebruikt vanwege veiligheidsrisico’s:
 Er gaan leesbare data door het netwerk.
 Je bent niet zeker met wie je verbonden bent
o Soms nog in gebruik bij router management op beschermde netwerksegmenten.

SSH:

 SSH (SECURE SHELL, RFC 4251..4254)
 Opvolger van TELNET
 SSH luistert op TCP-poort 22.
 Dezelfde functie als TELNET (remote terminal)
 Lijkt dus op TELNET maar is wel beveiligd:
 Wordt zeer vaak toegepast bij remote beheer van computers, routers en switches.
 Encryptie van de data
 Authenticatie van de verbinding (server moet bij het verbinden aantonen over een bepaalde
key te beschikken).

Bekende clients voor TELNET/SSH op Windows:

 SSH via PowerShell
 Putty




SSH en Security:

,Als je voor de eerste keer een server bezoekt, word je gewaarschuwd en moet je toestemming
geven.




Na het geven van toestemming wordt bij alle volgende sessies automatisch gecontroleerd of het
dezelfde server is (door middel van een geheime sleutel).

HTTP (Hyper Tekst Transfer Protocol):

 Het meest bekende internetprotocol (RFC1945.2616)
 HTTP-clients kunnen webpagina’s bij HTTP-servers opvragen (requests).
 Webpagina’s bestaan uit een of meerdere webobjecten (html, jpg, javascript, etc.)
 HTTP-servers luisteren meestal naar poort 80 of poort 443 en geven antwoord op requests in
de vorm van replies.

 Tegenwoordig is HTTP voor een groot deel vervangen door de veilige versie (HTTPS over
poort 443).




HTTP request-PDU:

, Opbouw van de request HTTP-PDU:

Hier zie je de:

 Methode
 URL link
 Versie
 ASCII codes bij de volgende regel (<cr><if>) (in de header)
 Value (in de header)
 Bij een GET request is de payload leeg omdat je juist data opvraagt en niet verzendt.




URL (Uniform Resource Locator):

Documentinformatie

Studie
Geüpload op
29 oktober 2019
Aantal pagina's
25
Geschreven in
2019/2020
Type
College aantekeningen
Docent(en)
Onbekend
Bevat
Alle colleges
€10,99

Verkeerd document? Gratis ruilen Binnen 14 dagen na aankoop en voor het downloaden kun je een ander document kiezen. Je kunt het bedrag gewoon opnieuw besteden.
Geschreven door studenten die geslaagd zijn
Direct beschikbaar na je betaling
Online lezen of als PDF

Seller avatar
De reputatie van een verkoper is gebaseerd op het aantal documenten dat iemand tegen betaling verkocht heeft en de beoordelingen die voor die items ontvangen zijn. Er zijn drie niveau’s te onderscheiden: brons, zilver en goud. Hoe beter de reputatie, hoe meer de kwaliteit van zijn of haar werk te vertrouwen is.
Eyespectre
3,4
(7)
Verkocht
59
Volgers
34
Items
17
Laatst verkocht
8 maanden geleden

Echte notities, van echte studenten
Elk document op Stuvia is geschreven door een medestudent die hetzelfde vak deed. Zo leer je van iemand die het al heeft gehaald.



Waarom studenten kiezen voor Stuvia

Gemaakt door medestudenten, geverifieerd door reviews

Kwaliteit die je kunt vertrouwen: geschreven door studenten die slaagden en beoordeeld door anderen die dit document gebruikten.

Niet tevreden? Kies een ander document

Geen zorgen! Je kunt voor hetzelfde geld direct een ander document kiezen dat beter past bij wat je zoekt.

Betaal zoals je wilt, start meteen met leren

Geen abonnement, geen verplichtingen. Betaal zoals je gewend bent via iDeal of creditcard en download je PDF-document meteen.

Student with book image

“Gekocht, gedownload en geslaagd. Zo makkelijk kan het dus zijn.”

Alisha Student

Bezig met je bronvermelding?

Maak nauwkeurige citaten in APA, MLA en Harvard met onze gratis bronnengenerator.

Bezig met je bronvermelding?

Veelgestelde vragen